cve.bz

CVE-2026-32829

8.2 highEPSS 0.6%

High (8.2) in pseitz lz4 flex. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in lz4_flex 0.11.6, 0.12.1.

lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0, decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 "match copy operations," allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.

Severity

CVSS 4.0

8.2 high
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
0.6% chance of exploitation in the next 30 days; higher than 49% of CVEs (scores of 2026-10-31)
CWEs
CWE-201, CWE-823
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-vvp9-7p8x-rfvvcrates.iolz4_flex<0.11.60.11.6
GHSA-vvp9-7p8x-rfvvcrates.iolz4_flex>=0.12.0 <0.12.10.12.1
RUSTSEC-2026-0041crates.iolz4_flex>=0.0.0-0 <0.11.6
>=0.12.0 <0.12.1
0.11.6, 0.12.1

References

Check your stackJSON