cve.bz

CVE-2025-67647

8.4 highEPSS 0.5%

High (8.4) in svelte. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in @sveltejs/kit 2.49.5.

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.

Severity

CVSS 4.0

8.4 high
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:H/SC:L/SI:L/SA:N

CVSS 3.1

9.1 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 43% of CVEs (scores of 2026-10-31)
CWEs
CWE-918, CWE-248
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-j62c-4x62-9r35npm@sveltejs/kit>=2.19.0 <2.49.52.49.5
GHSA-j62c-4x62-9r35npm@sveltejs/adapter-node>=5.4.1 <5.5.15.5.1

References

Check your stackJSON