cve.bz

CVE-2025-48912

7.1 highEPSS 0.8%

High (7.1) in apache superset. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in apache-superset 4.1.2.

An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.

Severity

CVSS 4.0

7.1 high
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
0.8% chance of exploitation in the next 30 days; higher than 56% of CVEs (scores of 2026-10-31)
CWE
CWE-89
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8w7f-8pr9-xgwjPyPIapache-superset<4.1.24.1.2
PYSEC-2026-1164PyPIapache-superset<4.1.24.1.2

References

Check your stackJSON