cve.bz

CVE-2024-39887

9.8 criticalEPSS 4.4%

Critical (9.8) in apache superset. EPSS 4.4% chance of exploitation in the next 30 days. Fixed in apache-superset 4.0.2.

An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. To mitigate this, a new configuration key named DISALLOWED_SQL_FUNCTIONS has been introduced. This key disallows the use of the following PostgreSQL functions: version, query_to_xml, inet_server_addr, and inet_client_addr. Additional functions can be added to this list for increased protection. This issue affects Apache Superset: before 4.0.2. Users are recommended to upgrade to version 4.0.2, which fixes the issue.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
4.4% chance of exploitation in the next 30 days; higher than 91% of CVEs (scores of 2026-10-31)
CWE
CWE-89
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-2q6j-vpvr-6pvjPyPIapache-superset<4.0.24.0.2
PYSEC-2026-1155PyPIapache-superset<4.0.24.0.2

References

Check your stackJSON