{"cve":"CVE-2024-39887","nvd":{"published":"2024-07-16T10:15:03.380","modified":"2026-06-17T07:42:58.257","status":"Modified","description":"An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. To mitigate this, a new configuration key named DISALLOWED_SQL_FUNCTIONS has been introduced. This key disallows the use of the following PostgreSQL functions: version, query_to_xml, inet_server_addr, and inet_client_addr. Additional functions can be added to this list for increased protection.\n\nThis issue affects Apache Superset: before 4.0.2.\n\nUsers are recommended to upgrade to version 4.0.2, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-89"],"references":["http://www.openwall.com/lists/oss-security/2024/07/16/5","https://lists.apache.org/thread/j55vm41jg3l0x6w49zrmvbf3k0ts5fqz","http://www.openwall.com/lists/oss-security/2024/07/16/5","https://lists.apache.org/thread/j55vm41jg3l0x6w49zrmvbf3k0ts5fqz"],"products":["apache:superset"],"source":"nvd","synced_at":"2026-10-19T21:52:42.518321223+00:00"},"epss":{"cve":"CVE-2024-39887","score":0.04433,"percentile":0.91381,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-2q6j-vpvr-6pvj","url":"https://osv.dev/vulnerability/GHSA-2q6j-vpvr-6pvj","summary":"Apache Superset vulnerable to improper SQL authorization","modified":"2026-07-07T17:57:26.607065124Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<4.0.2"],"fixed":["4.0.2"]}]},{"id":"PYSEC-2026-1155","url":"https://osv.dev/vulnerability/PYSEC-2026-1155","summary":"Apache Superset vulnerable to improper SQL authorization","modified":"2026-07-07T17:57:26.607065124Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<4.0.2"],"fixed":["4.0.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}