cve.bz

CVE-2022-31077

5.7 mediumEPSS 0.8%

Medium (5.7) in linuxfoundation kubeedge. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in github.com/kubeedge/kubeedge 1.10.1, 1.9.3.

KubeEdge is built upon Kubernetes and extends native containerized application orchestration and device management to hosts at the Edge. In affected versions a malicious message response from KubeEdge can crash the CSI Driver controller server by triggering a nil-pointer dereference panic. As a consequence, the CSI Driver controller will be in denial of service. This bug has been fixed in Kubeedge 1.11.0, 1.10.1, and 1.9.3. Users should update to these versions to resolve the issue. At the time of writing, no workaround exists.

Severity

CVSS 3.1

5.7 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H
EPSS
0.8% chance of exploitation in the next 30 days; higher than 57% of CVEs (scores of 2026-10-31)
CWE
CWE-476
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-x938-fvfw-7jh5Gogithub.com/kubeedge/kubeedge>=1.10.0 <1.10.11.10.1
GHSA-x938-fvfw-7jh5Gogithub.com/kubeedge/kubeedge<1.9.31.9.3
GO-2022-0501Gogithub.com/kubeedge/kubeedge<1.9.3
>=1.10.0 <1.10.1
1.9.3, 1.10.1

References

Check your stackJSON