cve.bz

CVE-2022-2422

9.8 criticalEPSS 0.9%

Critical (9.8) in feathersjs feathers-sequelize. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in feathers-sequelize 6.3.4.

Due to improper input validation in the Feathers js library, it is possible to perform a SQL injection attack on the back-end database, in case the feathers-sequelize package is used.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.9% chance of exploitation in the next 30 days; higher than 60% of CVEs (scores of 2026-10-31)
CWE
CWE-89
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qpv8-4pjq-qqh7npmfeathers-sequelize>=6.0.0 <6.3.46.3.4

References

Check your stackJSON