{"cve":"CVE-2022-2422","nvd":{"published":"2022-10-26T10:15:16.993","modified":"2026-06-17T04:41:52.057","status":"Modified","description":"Due to improper input validation in the Feathers js library, it is possible to perform a SQL injection attack on the back-end database, in case the feathers-sequelize package is used.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-89"],"references":["https://csirt.divd.nl/CVE-2022-2422","https://csirt.divd.nl/DIVD-2022-00020","https://csirt.divd.nl/CVE-2022-2422","https://csirt.divd.nl/DIVD-2022-00020"],"products":["feathersjs:feathers-sequelize"],"source":"nvd","synced_at":"2026-10-19T21:37:08.729216836+00:00"},"epss":{"cve":"CVE-2022-2422","score":0.00931,"percentile":0.60632,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-qpv8-4pjq-qqh7","url":"https://osv.dev/vulnerability/GHSA-qpv8-4pjq-qqh7","summary":"feathers-sequelize contains improper input validation leading to SQL injection","modified":"2023-11-08T04:08:30.007599Z","packages":[{"ecosystem":"npm","name":"feathers-sequelize","purl":"pkg:npm/feathers-sequelize","ranges":[">=6.0.0 <6.3.4"],"fixed":["6.3.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}