cve.bz

CVE-2026-75858

8.5 highEPSS 0.4%

CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.

CVSS 4.0
8.5CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.8CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 30% of CVEs (scores of 2026-10-25)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-wrj3-vj8c-784fcrates.iodeepseek-tui>=0.8.33 <=0.8.41no fix published
GHSA-wrj3-vj8c-784fnpmdeepseek-tui>=0.8.33 <0.8.410.8.41
GHSA-wrj3-vj8c-784fcrates.iocodewhale-tui>=0.8.41 <0.8.640.8.64
GHSA-wrj3-vj8c-784fnpmcodewhale>=0.8.41 <0.8.640.8.64

References

Check your stackJSON