{"cve":"CVE-2026-75858","nvd":{"published":"2026-08-18T16:18:21.653","modified":"2026-10-22T22:10:00.250","status":"Deferred","description":"CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.","cvss_v4":{"vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","score":8.5},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":7.8},"cwes":["CWE-94"],"references":["https://github.com/Hmbown/CodeWhale/commit/57f3c89471e27ac4032d9791f6885e5d4408c381","https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-wrj3-vj8c-784f","https://www.vulncheck.com/advisories/codewhale-rlm-eval-before-remote-code-execution","https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-wrj3-vj8c-784f"],"products":[],"source":"nvd","synced_at":"2026-10-23T16:39:26.291718493+00:00"},"epss":{"cve":"CVE-2026-75858","score":0.00364,"percentile":0.30008,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-wrj3-vj8c-784f","url":"https://osv.dev/vulnerability/GHSA-wrj3-vj8c-784f","summary":"CodeWhale: rlm_eval auto-approves arbitrary Python execution, bypassing the user's approval policy (RCE)","modified":"2026-09-04T19:00:04.292541165Z","packages":[{"ecosystem":"crates.io","name":"deepseek-tui","purl":"pkg:cargo/deepseek-tui","ranges":[">=0.8.33 <=0.8.41"],"fixed":[]},{"ecosystem":"npm","name":"deepseek-tui","purl":"pkg:npm/deepseek-tui","ranges":[">=0.8.33 <0.8.41"],"fixed":["0.8.41"]},{"ecosystem":"crates.io","name":"codewhale-tui","purl":"pkg:cargo/codewhale-tui","ranges":[">=0.8.41 <0.8.64"],"fixed":["0.8.64"]},{"ecosystem":"npm","name":"codewhale","purl":"pkg:npm/codewhale","ranges":[">=0.8.41 <0.8.64"],"fixed":["0.8.64"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}