cve.bz

CVE-2026-75857

7.3 highEPSS 0.2%

CodeWhale versions >= 0.8.41 and < 0.8.64 contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in 0.8.64.

CVSS 4.0
7.3CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.0CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 4% of CVEs (scores of 2026-10-25)
CWE
CWE-269
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-g29h-pfmp-qp9rcrates.iodeepseek-tui>=0.3.10 <=0.8.41no fix published
GHSA-g29h-pfmp-qp9rnpmdeepseek-tui>=0.3.10 <0.8.410.8.41
GHSA-g29h-pfmp-qp9rcrates.iocodewhale-tui>=0.8.41 <0.8.640.8.64
GHSA-g29h-pfmp-qp9rnpmcodewhale>=0.8.41 <0.8.640.8.64

References

Check your stackJSON