{"cve":"CVE-2026-75857","nvd":{"published":"2026-08-18T16:18:21.520","modified":"2026-10-22T22:10:00.250","status":"Deferred","description":"CodeWhale versions >= 0.8.41 and < 0.8.64 contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in 0.8.64.","cvss_v4":{"vector":"CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","score":7.3},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","score":7.0},"cwes":["CWE-269"],"references":["https://github.com/Hmbown/CodeWhale/commit/57f3c89471e27ac4032d9791f6885e5d4408c381","https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r","https://www.vulncheck.com/advisories/codewhale-before-privilege-escalation-via-exec-shell-interact","https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r"],"products":[],"source":"nvd","synced_at":"2026-10-23T16:39:26.291718493+00:00"},"epss":{"cve":"CVE-2026-75857","score":0.00155,"percentile":0.04528,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-g29h-pfmp-qp9r","url":"https://osv.dev/vulnerability/GHSA-g29h-pfmp-qp9r","summary":"CodeWhale: exec_shell_interact sends LLM-controlled input to a running shell without an approval prompt (privilege escalation)","modified":"2026-09-04T19:00:04.276620399Z","packages":[{"ecosystem":"crates.io","name":"deepseek-tui","purl":"pkg:cargo/deepseek-tui","ranges":[">=0.3.10 <=0.8.41"],"fixed":[]},{"ecosystem":"npm","name":"deepseek-tui","purl":"pkg:npm/deepseek-tui","ranges":[">=0.3.10 <0.8.41"],"fixed":["0.8.41"]},{"ecosystem":"crates.io","name":"codewhale-tui","purl":"pkg:cargo/codewhale-tui","ranges":[">=0.8.41 <0.8.64"],"fixed":["0.8.64"]},{"ecosystem":"npm","name":"codewhale","purl":"pkg:npm/codewhale","ranges":[">=0.8.41 <0.8.64"],"fixed":["0.8.64"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}