cve.bz

CVE-2026-59898

6.3 mediumEPSS 0.4%

Medium (6.3) in netty netty. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in io.netty:netty-codec-http 4.1.136.Final, 4.2.16.Final.

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.

Severity

CVSS 4.0

6.3 medium
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 38% of CVEs (scores of 2026-10-31)
CWE
CWE-444
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4mp9-239f-g9hgMavenio.netty:netty-codec-http>=4.2.0.Final <4.2.16.Final4.2.16.Final
GHSA-4mp9-239f-g9hgMavenio.netty:netty-codec-http<4.1.136.Final4.1.136.Final

References

Check your stackJSON