{"cve":"CVE-2026-59898","nvd":{"published":"2026-07-29T19:16:48.740","modified":"2026-08-06T20:35:23.360","status":"Analyzed","description":"Netty is an asynchronous, event-driven network application framework.  Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","score":6.3},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","score":7.5},"cwes":["CWE-444"],"references":["https://github.com/netty/netty/releases/tag/netty-4.1.136.Final","https://github.com/netty/netty/releases/tag/netty-4.2.16.Final","https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hg"],"products":["netty:netty"],"source":"nvd","synced_at":"2026-10-19T22:46:40.600842820+00:00"},"epss":{"cve":"CVE-2026-59898","score":0.00439,"percentile":0.38173,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-4mp9-239f-g9hg","url":"https://osv.dev/vulnerability/GHSA-4mp9-239f-g9hg","summary":"Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation","modified":"2026-09-10T03:51:10.413004153Z","packages":[{"ecosystem":"Maven","name":"io.netty:netty-codec-http","purl":"pkg:maven/io.netty/netty-codec-http","ranges":[">=4.2.0.Final <4.2.16.Final"],"fixed":["4.2.16.Final"]},{"ecosystem":"Maven","name":"io.netty:netty-codec-http","purl":"pkg:maven/io.netty/netty-codec-http","ranges":["<4.1.136.Final"],"fixed":["4.1.136.Final"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}