CVE-2026-59822
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, LiteLLM's MCP Streamable HTTP endpoint allowed an unauthenticated attacker to use a fabricated Authorization header to trigger an OAuth2 passthrough fallback path that replaced failed LiteLLM key validation with an empty UserAPIKeyAuth() object, allowing requests to reach MCP tooling without a valid LiteLLM key. This issue is fixed in version 1.84.0.
- CVSS 4.0
- 8.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 8.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - EPSS
- 0.8% chance of exploitation in the next 30 days; higher than 57% of CVEs (scores of 2026-10-25)
- CISA KEV
- listed 2026-09-02, due 2026-09-16
- CWEs
- CWE-287, CWE-306
- Published
- Modified
- Record from
- the NVD, synced
Affected
- litellm:litellm
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-7488-6r32-c95q | PyPI | litellm | <1.84.0 | 1.84.0 |
| PYSEC-2026-3479 | PyPI | litellm | <1.84.0 | 1.84.0 |
References
- https://github.com/BerriAI/litellm/commit/73869f0faf7d11ee21adcb5f91b8c33a340b6c2c
- https://github.com/BerriAI/litellm/pull/26463
- https://github.com/BerriAI/litellm/releases/tag/v1.84.0
- https://github.com/BerriAI/litellm/security/advisories/GHSA-7488-6r32-c95q
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-59822