{"cve":"CVE-2026-59822","nvd":{"published":"2026-07-08T20:16:57.683","modified":"2026-10-25T17:10:00.197","status":"Analyzed","description":"LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, LiteLLM's MCP Streamable HTTP endpoint allowed an unauthenticated attacker to use a fabricated Authorization header to trigger an OAuth2 passthrough fallback path that replaced failed LiteLLM key validation with an empty UserAPIKeyAuth() object, allowing requests to reach MCP tooling without a valid LiteLLM key. This issue is fixed in version 1.84.0.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N","score":8.8},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","score":8.2},"cwes":["CWE-287","CWE-306"],"references":["https://github.com/BerriAI/litellm/commit/73869f0faf7d11ee21adcb5f91b8c33a340b6c2c","https://github.com/BerriAI/litellm/pull/26463","https://github.com/BerriAI/litellm/releases/tag/v1.84.0","https://github.com/BerriAI/litellm/security/advisories/GHSA-7488-6r32-c95q","https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-59822"],"products":["litellm:litellm"],"source":"nvd","synced_at":"2026-10-25T17:50:06.907763985+00:00"},"epss":{"cve":"CVE-2026-59822","score":0.00836,"percentile":0.57449,"date":"2026-10-25"},"kev":{"cve":"CVE-2026-59822","date_added":"2026-09-02","due_date":"2026-09-16","vendor":"BerriAI","product":"LiteLLM","known_ransomware":false},"osv":[{"id":"GHSA-7488-6r32-c95q","url":"https://osv.dev/vulnerability/GHSA-7488-6r32-c95q","summary":"LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback","modified":"2026-09-10T03:51:10.889726310Z","packages":[{"ecosystem":"PyPI","name":"litellm","purl":"pkg:pypi/litellm","ranges":["<1.84.0"],"fixed":["1.84.0"]}]},{"id":"PYSEC-2026-3479","url":"https://osv.dev/vulnerability/PYSEC-2026-3479","summary":"LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback","modified":"2026-07-23T15:00:13.909880217Z","packages":[{"ecosystem":"PyPI","name":"litellm","purl":"pkg:pypi/litellm","ranges":["<1.84.0"],"fixed":["1.84.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}