CVE-2026-47761
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
- CVSS 3.1
- 5.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 18% of CVEs (scores of 2026-10-25)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- tiny:tinymce
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-vg35-5wq7-3x7w | npm | tinymce | <=5.10.9 | no fix published |
| GHSA-vg35-5wq7-3x7w | npm | tinymce | >=6.0.0 <7.9.3 | 7.9.3 |
| GHSA-vg35-5wq7-3x7w | npm | tinymce | >=8.0.0 <8.5.1 | 8.5.1 |
| GHSA-vg35-5wq7-3x7w | NuGet | TinyMCE | <=5.10.9 | no fix published |
| GHSA-vg35-5wq7-3x7w | NuGet | TinyMCE | >=6.0.0 <7.9.3 | 7.9.3 |
| GHSA-vg35-5wq7-3x7w | NuGet | TinyMCE | >=8.0.0 <8.5.1 | 8.5.1 |
| GHSA-vg35-5wq7-3x7w | Packagist | tinymce/tinymce | <=5.10.9 | no fix published |
| GHSA-vg35-5wq7-3x7w | Packagist | tinymce/tinymce | >=6.0.0 <7.9.3 | 7.9.3 |
| GHSA-vg35-5wq7-3x7w | Packagist | tinymce/tinymce | >=8.0.0 <8.5.1 | 8.5.1 |