cve.bz

CVE-2026-44578

8.6 highEPSS 36%

Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.

CVSS 3.1
8.6CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
36% chance of exploitation in the next 30 days; higher than 98% of CVEs (scores of 2026-10-25)
CWE
CWE-918
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-c4j6-fc7j-m34rnpmnext>=13.4.13 <15.5.1615.5.16
GHSA-c4j6-fc7j-m34rnpmnext>=16.0.0 <16.2.516.2.5

References

Check your stackJSON