cve.bz

CVE-2026-44166

6.1 mediumEPSS 0.2%

Medium (6.1) in pocketbase pocketbase. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in github.com/pocketbase/pocketbase 0.22.42, 0.37.4.

Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. "A". When the victim gets invited or decides to sign up to your app on their own with provider "B" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to "verified" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.

Severity

CVSS 4.0

6.1 medium
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N

CVSS 3.1

7.6 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L
EPSS
0.2% chance of exploitation in the next 30 days; higher than 16% of CVEs (scores of 2026-10-31)
CWE
CWE-287
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pq7p-mc74-g65wGogithub.com/pocketbase/pocketbase<0.22.420.22.42
GHSA-pq7p-mc74-g65wGogithub.com/pocketbase/pocketbase>=0.30.0 <0.37.40.37.4
GO-2026-5548Gogithub.com/pocketbase/pocketbase<0.22.42
>=0.30.0 <0.37.4
0.22.42, 0.37.4

References

Check your stackJSON