{"cve":"CVE-2026-44166","nvd":{"published":"2026-05-12T18:17:29.123","modified":"2026-06-17T10:50:18.640","status":"Analyzed","description":"Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. \"A\". When the victim gets invited or decides to sign up to your app on their own with provider \"B\" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to \"verified\" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N","score":6.1},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L","score":7.6},"cwes":["CWE-287"],"references":["https://github.com/pocketbase/pocketbase/security/advisories/GHSA-pq7p-mc74-g65w"],"products":["pocketbase:pocketbase"],"source":"nvd","synced_at":"2026-10-19T22:35:16.954578616+00:00"},"epss":{"cve":"CVE-2026-44166","score":0.00247,"percentile":0.16074,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-pq7p-mc74-g65w","url":"https://osv.dev/vulnerability/GHSA-pq7p-mc74-g65w","summary":"PocketBase vulnerable to account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade","modified":"2026-07-24T19:11:28.110305996Z","packages":[{"ecosystem":"Go","name":"github.com/pocketbase/pocketbase","purl":"pkg:golang/github.com/pocketbase/pocketbase","ranges":["<0.22.42"],"fixed":["0.22.42"]},{"ecosystem":"Go","name":"github.com/pocketbase/pocketbase","purl":"pkg:golang/github.com/pocketbase/pocketbase","ranges":[">=0.30.0 <0.37.4"],"fixed":["0.37.4"]}]},{"id":"GO-2026-5548","url":"https://osv.dev/vulnerability/GO-2026-5548","summary":"PocketBase: Account pre-hijacking via OAuth2 autolinking upgrade in github.com/pocketbase/pocketbase","modified":"2026-07-24T19:00:24.118962034Z","packages":[{"ecosystem":"Go","name":"github.com/pocketbase/pocketbase","purl":"pkg:golang/github.com/pocketbase/pocketbase","ranges":["<0.22.42",">=0.30.0 <0.37.4"],"fixed":["0.22.42","0.37.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}