CVE-2026-43514
Observable Timing Discrepancy vulnerability when comparing AJP secret in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Older unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.
- CVSS 3.1
- 3.7
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 28% of CVEs (scores of 2026-10-26)
- CWE
- CWE-208
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:tomcat
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-9m89-8frq-c98c | Maven | org.apache.tomcat.embed:tomcat-embed-core | <9.0.118 | 9.0.118 |
| GHSA-9m89-8frq-c98c | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=10.1.0-M1 <10.1.55 | 10.1.55 |
| GHSA-9m89-8frq-c98c | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=11.0.0-M1 <11.0.22 | 11.0.22 |
| GHSA-9m89-8frq-c98c | Maven | org.apache.tomcat:tomcat | <9.0.118 | 9.0.118 |
| GHSA-9m89-8frq-c98c | Maven | org.apache.tomcat:tomcat | >=10.1.0-M1 <10.1.55 | 10.1.55 |
| GHSA-9m89-8frq-c98c | Maven | org.apache.tomcat:tomcat | >=11.0.0-M1 <11.0.22 | 11.0.22 |
| GHSA-9m89-8frq-c98c | Maven | org.apache.tomcat:tomcat-catalina | <9.0.118 | 9.0.118 |
| GHSA-9m89-8frq-c98c | Maven | org.apache.tomcat:tomcat-catalina | >=10.1.0-M1 <10.1.55 | 10.1.55 |
| GHSA-9m89-8frq-c98c | Maven | org.apache.tomcat:tomcat-catalina | >=11.0.0-M1 <11.0.22 | 11.0.22 |