CVE-2026-42271
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
- CVSS 4.0
- 8.7
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N - CVSS 3.1
- 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - EPSS
- 91% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-26)
- CISA KEV
- listed 2026-06-08, due 2026-06-22
- CWEs
- CWE-77, CWE-78
- Published
- Modified
- Record from
- the NVD, synced
Affected
- litellm:litellm
- redhat:openshift_ai
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-v4p8-mg3p-g94g | PyPI | litellm | >=1.74.2 <1.83.7 | 1.83.7 |
| PYSEC-2026-2599 | PyPI | litellm | >=1.74.2 <1.83.7 | 1.83.7 |