CVE-2026-41271
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) vulnerability exists in FlowiseAI's POST/GET API Chain components that allows unauthenticated attackers to force the server to make arbitrary HTTP requests to internal and external systems. By injecting malicious prompt templates, attackers can bypass the intended API documentation constraints and redirect requests to sensitive internal services, potentially leading to internal network reconnaissance and data exfiltration. This vulnerability is fixed in 3.1.0.
- CVSS 3.1
- 8.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L - EPSS
- 0.2% chance of exploitation in the next 30 days; higher than 14% of CVEs (scores of 2026-10-26)
- CWE
- CWE-918
- Published
- Modified
- Record from
- the NVD, synced
Affected
- flowiseai:flowise
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-6r77-hqx7-7vw8 | npm | flowise | <3.1.0 | 3.1.0 |
| GHSA-6r77-hqx7-7vw8 | npm | flowise-components | <3.1.0 | 3.1.0 |