cve.bz

CVE-2026-32773

6.1 mediumEPSS 0.4%

Medium (6.1) in apache spark. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in pyspark 3.5.8.

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 35% of CVEs (scores of 2026-10-31)
CWE
CWE-80
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9437-39hj-3c93PyPIpyspark>=3.0.0 <3.5.83.5.8
GHSA-9437-39hj-3c93Mavenorg.apache.spark:spark-core_2.12>=3.0.0 <3.5.83.5.8
GHSA-9437-39hj-3c93Mavenorg.apache.spark:spark-core_2.13>=3.0.0 <3.5.83.5.8
PYSEC-2026-3966PyPIpyspark>=3.0.0 <3.5.83.5.8

References

Check your stackJSON