{"cve":"CVE-2026-32773","nvd":{"published":"2026-09-02T11:17:20.173","modified":"2026-09-08T13:04:14.690","status":"Analyzed","description":"There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later.\n\nThis CVE is marked as \"low\" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page.\n\nUsers are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-80"],"references":["https://lists.apache.org/thread/k36prh3oxl1z6ov7w8rpmfnt07hmzw3v","http://www.openwall.com/lists/oss-security/2026/09/01/4"],"products":["apache:spark"],"source":"nvd","synced_at":"2026-10-19T22:50:50.842544443+00:00"},"epss":{"cve":"CVE-2026-32773","score":0.00414,"percentile":0.35777,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-9437-39hj-3c93","url":"https://osv.dev/vulnerability/GHSA-9437-39hj-3c93","summary":"Apache Spark History Server allows stored cross-site scripting through unescaped application names","modified":"2026-10-05T23:10:51.868340776Z","packages":[{"ecosystem":"PyPI","name":"pyspark","purl":"pkg:pypi/pyspark","ranges":[">=3.0.0 <3.5.8"],"fixed":["3.5.8"]},{"ecosystem":"Maven","name":"org.apache.spark:spark-core_2.12","purl":"pkg:maven/org.apache.spark/spark-core_2.12","ranges":[">=3.0.0 <3.5.8"],"fixed":["3.5.8"]},{"ecosystem":"Maven","name":"org.apache.spark:spark-core_2.13","purl":"pkg:maven/org.apache.spark/spark-core_2.13","ranges":[">=3.0.0 <3.5.8"],"fixed":["3.5.8"]}]},{"id":"PYSEC-2026-3966","url":"https://osv.dev/vulnerability/PYSEC-2026-3966","summary":"","modified":"2026-10-15T14:45:14.801306067Z","packages":[{"ecosystem":"PyPI","name":"pyspark","purl":"pkg:pypi/pyspark","ranges":[">=3.0.0 <3.5.8"],"fixed":["3.5.8"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}