cve.bz

CVE-2026-30962

7.1 highEPSS 0.3%

High (7.1) in parseplatform parse-server. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in parse-server 8.6.19, 9.5.2-alpha.6.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.

Severity

CVSS 4.0

7.1 high
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
0.3% chance of exploitation in the next 30 days; higher than 24% of CVEs (scores of 2026-10-31)
CWE
CWE-284
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-72hp-qff8-4pvvnpmparse-server>=9.0.0 <9.5.2-alpha.69.5.2-alpha.6
GHSA-72hp-qff8-4pvvnpmparse-server<8.6.198.6.19

References

Check your stackJSON