cve.bz

CVE-2026-24733

3.7 lowEPSS 0.6%

Low (3.7) in apache tomcat. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in org.apache.tomcat:tomcat-coyote 10.1.50, 11.0.15, 9.0.113.

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Severity

CVSS 3.1

3.7 low
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
0.6% chance of exploitation in the next 30 days; higher than 46% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qq5r-98hh-rxc9Mavenorg.apache.tomcat:tomcat-coyote>=11.0.0-M1 <11.0.1511.0.15
GHSA-qq5r-98hh-rxc9Mavenorg.apache.tomcat:tomcat-coyote>=10.1.0-M1 <10.1.5010.1.50
GHSA-qq5r-98hh-rxc9Mavenorg.apache.tomcat:tomcat-coyote<9.0.1139.0.113

References

Check your stackJSON