{"cve":"CVE-2026-24733","nvd":{"published":"2026-02-17T19:21:56.820","modified":"2026-06-17T10:23:30.013","status":"Modified","description":"Improper Input Validation vulnerability in Apache Tomcat.\n\n\nTomcat did not limit HTTP/0.9 requests to the GET method. If a security \nconstraint was configured to allow HEAD requests to a URI but deny GET \nrequests, the user could bypass that constraint on GET requests by \nsending a (specification invalid) HEAD request using HTTP/0.9.\n\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112.\n\n\nOlder, EOL versions are also affected.\n\nUsers are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N","score":3.7},"cwes":["CWE-20"],"references":["https://lists.apache.org/thread/6xk3t65qpn1myp618krtfotbjn1qt90f"],"products":["apache:tomcat"],"source":"nvd","synced_at":"2026-10-19T22:23:35.260773158+00:00"},"epss":{"cve":"CVE-2026-24733","score":0.00552,"percentile":0.46128,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-qq5r-98hh-rxc9","url":"https://osv.dev/vulnerability/GHSA-qq5r-98hh-rxc9","summary":"Apache Tomcat - Security constraint bypass with HTTP/0.9","modified":"2026-09-11T08:25:53.089788485Z","packages":[{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=11.0.0-M1 <11.0.15"],"fixed":["11.0.15"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=10.1.0-M1 <10.1.50"],"fixed":["10.1.50"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":["<9.0.113"],"fixed":["9.0.113"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}