cve.bz

CVE-2026-23897

7.5 highEPSS 0.7%

High (7.5) in apollographql apollo server. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in @apollo/server 4.13.0, 5.4.0.

Apollo Server is an open-source, spec-compliant GraphQL server that's compatible with any GraphQL client, including Apollo Client. In versions from 2.0.0 to 3.13.0, 4.2.0 to before 4.13.0, and 5.0.0 to before 5.4.0, the default configuration of startStandaloneServer from @apollo/server/standalone is vulnerable to denial of service (DoS) attacks through specially crafted request bodies with exotic character set encodings. This issue does not affect users that use @apollo/server as a dependency for integration packages, like @as-integrations/express5 or @as-integrations/next, only direct usage of startStandaloneServer.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.7% chance of exploitation in the next 30 days; higher than 52% of CVEs (scores of 2026-10-31)
CWE
CWE-1333
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-mp6q-xf9x-fwf7npmapollo-server>=2.0.0 <=3.13.0no fix published
GHSA-mp6q-xf9x-fwf7npm@apollo/server>=4.2.0 <4.13.04.13.0
GHSA-mp6q-xf9x-fwf7npm@apollo/server>=5.0.0 <5.4.05.4.0

References

Check your stackJSON