{"cve":"CVE-2026-23897","nvd":{"published":"2026-02-04T20:16:05.130","modified":"2026-06-17T10:22:16.480","status":"Analyzed","description":"Apollo Server is an open-source, spec-compliant GraphQL server that's compatible with any GraphQL client, including Apollo Client. In versions from 2.0.0 to 3.13.0, 4.2.0 to before 4.13.0, and 5.0.0 to before 5.4.0, the default configuration of startStandaloneServer from @apollo/server/standalone is vulnerable to denial of service (DoS) attacks through specially crafted request bodies with exotic character set encodings. This issue does not affect users that use @apollo/server as a dependency for integration packages, like @as-integrations/express5 or @as-integrations/next, only direct usage of startStandaloneServer.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-1333"],"references":["https://github.com/apollographql/apollo-server/commit/d25a5bdc377826ad424fcf7f8d1d062055911643","https://github.com/apollographql/apollo-server/commit/e9d49d163a86b8a33be56ed27c494b9acd5400a4","https://github.com/apollographql/apollo-server/security/advisories/GHSA-mp6q-xf9x-fwf7"],"products":["apollographql:apollo_server"],"source":"nvd","synced_at":"2026-10-19T22:22:27.261130201+00:00"},"epss":{"cve":"CVE-2026-23897","score":0.00689,"percentile":0.52763,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-mp6q-xf9x-fwf7","url":"https://osv.dev/vulnerability/GHSA-mp6q-xf9x-fwf7","summary":"Apollo Serve vulnerable to Denial of Service with `startStandaloneServer`","modified":"2026-02-04T21:55:11Z","packages":[{"ecosystem":"npm","name":"apollo-server","purl":"pkg:npm/apollo-server","ranges":[">=2.0.0 <=3.13.0"],"fixed":[]},{"ecosystem":"npm","name":"@apollo/server","purl":"pkg:npm/%40apollo/server","ranges":[">=4.2.0 <4.13.0"],"fixed":["4.13.0"]},{"ecosystem":"npm","name":"@apollo/server","purl":"pkg:npm/%40apollo/server","ranges":[">=5.0.0 <5.4.0"],"fixed":["5.4.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}