CVE-2026-106459
Backstage is an open framework for building developer portals. From 0.3.0 until 0.3.8, the @backstage/plugin-scaffolder-backend-module-sentry package is affected by improper input validation in sentry scaffolder actions. An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token. This issue is fixed in version 0.3.8.
- CVSS 3.1
- 8.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N - EPSS
- 0.2% chance of exploitation in the next 30 days; higher than 11% of CVEs (scores of 2026-10-25)
- CWEs
- CWE-200, CWE-918
- Published
- Modified
- Record from
- the NVD, synced
Affected
- linuxfoundation:backstage
- linuxfoundation:backstage\/plugin-scaffolder-backend-module-sentry
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-g734-fhp4-7mfp | npm | @backstage/plugin-scaffolder-backend-module-sentry | >=0.3.0 <0.3.8 | 0.3.8 |