CVE-2025-69264
pnpm is a package manager. Versions 10.0.0 through 10.25 allow git-hosted dependencies to execute arbitrary code during pnpm install, circumventing the v10 security feature "Dependency lifecycle scripts execution disabled by default". While pnpm v10 blocks postinstall scripts via the onlyBuiltDependencies mechanism, git dependencies can still execute prepare, prepublish, and prepack scripts during the fetch phase, enabling remote code execution without user consent or approval. This issue is fixed in version 10.26.0.
- CVSS 3.1
- 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - EPSS
- 1.0% chance of exploitation in the next 30 days; higher than 62% of CVEs (scores of 2026-10-25)
- CWE
- CWE-693
- Published
- Modified
- Record from
- the NVD, synced
Affected
- pnpm:pnpm
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-379q-355j-w6rj | npm | pnpm | >=10.0.0 <10.26.0 | 10.26.0 |
References
- https://github.com/pnpm/pnpm/commit/73cc63504d9bc360c43e4b2feb9080677f03c5b5
- https://github.com/pnpm/pnpm/security/advisories/GHSA-379q-355j-w6rj
- https://access.redhat.com/security/cve/CVE-2025-69264
- https://bugzilla.redhat.com/show_bug.cgi?id=2427709
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-69264.json