CVE-2025-66627
Wasmi is a WebAssembly interpreter focused on constrained and embedded systems. In versions 0.41.0, 0.41.1, 0.42.0 through 0.47.1, 0.50.0 through 0.51.2 and 1.0.0, Wasmi's linear memory implementation leads to a Use After Free vulnerability, triggered by a WebAssembly module under certain memory growth conditions. This issue potentially leads to memory corruption, information disclosure, or code execution. This issue is fixed in versions 0.41.2, 0.47.1, 0.51.3 and 1.0.1. To workaround this issue, consider limiting the maximum linear memory sizes where feasible.
- CVSS 3.1
- 7.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - EPSS
- 0.1% chance of exploitation in the next 30 days; higher than 3% of CVEs (scores of 2026-10-25)
- CWE
- CWE-416
- Published
- Modified
- Record from
- the NVD, synced
Affected
- wasmi-labs:wasmi
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-g4v2-cjqp-rfmq | crates.io | wasmi | >=0.41.0 <0.41.2 | 0.41.2 |
| GHSA-g4v2-cjqp-rfmq | crates.io | wasmi | >=0.42.0 <0.47.1 | 0.47.1 |
| GHSA-g4v2-cjqp-rfmq | crates.io | wasmi | >=0.50.0 <0.51.3 | 0.51.3 |
| GHSA-g4v2-cjqp-rfmq | crates.io | wasmi | >=1.0.0 <1.0.1 | 1.0.1 |