CVE-2025-66388
A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secrets to users without the appropriate authorization. Users are recommended to upgrade to version 3.1.4, which fixes this issue.
- CVSS 3.1
- 6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - EPSS
- 0.5% chance of exploitation in the next 30 days; higher than 41% of CVEs (scores of 2026-10-25)
- CWE
- CWE-201
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:airflow
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-fv47-pqh6-wxgq | PyPI | apache-airflow | >=3.1.0 <3.1.5 | 3.1.5 |
| PYSEC-2025-86 | PyPI | apache-airflow | >=3.1.0 <3.1.4 | 3.1.4 |