CVE-2025-65106
LangChain is a framework for building agents and LLM-powered applications. From versions 0.3.79 and prior and 1.0.0 to 1.0.6, a template injection vulnerability exists in LangChain's prompt template system that allows attackers to access Python object internals through template syntax. This vulnerability affects applications that accept untrusted template strings (not just template variables) in ChatPromptTemplate and related prompt template classes. This issue has been patched in versions 0.3.80 and 1.0.7.
- CVSS 4.0
- 8.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N - EPSS
- 0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-10-25)
- CWE
- CWE-1336
- Published
- Modified
- Record from
- the NVD, synced
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-6qv9-48xg-fc7f | PyPI | langchain-core | >=1.0.0 <1.0.7 | 1.0.7 |
| GHSA-6qv9-48xg-fc7f | PyPI | langchain-core | <0.3.80 | 0.3.80 |
| PYSEC-2026-1518 | PyPI | langchain-core | <0.3.80 >=1.0.0 <1.0.7 | 0.3.80, 1.0.7 |