{"cve":"CVE-2025-65106","nvd":{"published":"2025-11-21T22:16:32.933","modified":"2026-10-19T13:10:00.110","status":"Deferred","description":"LangChain is a framework for building agents and LLM-powered applications. From versions 0.3.79 and prior and 1.0.0 to 1.0.6, a template injection vulnerability exists in LangChain's prompt template system that allows attackers to access Python object internals through template syntax. This vulnerability affects applications that accept untrusted template strings (not just template variables) in ChatPromptTemplate and related prompt template classes. This issue has been patched in versions 0.3.80 and 1.0.7.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N","score":8.3},"cvss_v3":null,"cwes":["CWE-1336"],"references":["https://github.com/langchain-ai/langchain/commit/c4b6ba254e1a49ed91f2e268e6484011c540542a","https://github.com/langchain-ai/langchain/commit/fa7789d6c21222b85211755d822ef698d3b34e00","https://github.com/langchain-ai/langchain/security/advisories/GHSA-6qv9-48xg-fc7f"],"products":[],"source":"nvd","synced_at":"2026-10-19T22:16:02.354564667+00:00"},"epss":{"cve":"CVE-2025-65106","score":0.00524,"percentile":0.44172,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-6qv9-48xg-fc7f","url":"https://osv.dev/vulnerability/GHSA-6qv9-48xg-fc7f","summary":"LangChain Vulnerable to Template Injection via Attribute Access in Prompt Templates","modified":"2026-09-10T03:50:30.757129019Z","packages":[{"ecosystem":"PyPI","name":"langchain-core","purl":"pkg:pypi/langchain-core","ranges":[">=1.0.0 <1.0.7"],"fixed":["1.0.7"]},{"ecosystem":"PyPI","name":"langchain-core","purl":"pkg:pypi/langchain-core","ranges":["<0.3.80"],"fixed":["0.3.80"]}]},{"id":"PYSEC-2026-1518","url":"https://osv.dev/vulnerability/PYSEC-2026-1518","summary":"LangChain Vulnerable to Template Injection via Attribute Access in Prompt Templates","modified":"2026-07-07T17:46:47.156056540Z","packages":[{"ecosystem":"PyPI","name":"langchain-core","purl":"pkg:pypi/langchain-core","ranges":["<0.3.80",">=1.0.0 <1.0.7"],"fixed":["0.3.80","1.0.7"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}