cve.bz

CVE-2025-62728

5.4 mediumEPSS 0.4%

Medium (5.4) in apache hive. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in org.apache.hive:hive-common 4.2.0.

SQL injection vulnerability in Hive Metastore Server (HMS) when processing delete column statistics requests via the Thrift APIs. The vulnerability is only exploitable by trusted/authorized users/applications that are allowed to call directly the Thrift APIs. In most real-world deployments, HMS is accessible to only a handful of applications (e.g., Hiveserver2) thus the vulnerability is not exploitable. Moreover, the vulnerable code cannot be reached when metastore.try.direct.sql property is set to false. This issue affects Apache Hive: from 4.1.0 before 4.2.0. Users are recommended to upgrade to version 4.2.0, which fixes the issue. Users who cannot upgrade directly are encouraged to set metastore.try.direct.sql property to false if the HMS Thrift APIs are exposed to general public.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 36% of CVEs (scores of 2026-10-31)
CWE
CWE-89
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-932v-x9x2-vq29Mavenorg.apache.hive:hive-common>=4.1.0 <4.2.04.2.0
GHSA-932v-x9x2-vq29Mavenorg.apache.hive:hive-metastore>=4.1.0 <4.2.04.2.0

References

Check your stackJSON