CVE-2025-62228
Apache Flink CDC version 3.4.0 was vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, we recommend users update Flink CDC version to 3.5.0 which address this issue.
- CVSS 4.0
- 5.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/R:U/V:C/RE:L/U:Amber - CVSS 3.1
- 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - EPSS
- 0.5% chance of exploitation in the next 30 days; higher than 39% of CVEs (scores of 2026-10-25)
- CWE
- CWE-89
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:flink_cdc
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-wqm3-w3p6-xjgm | Maven | org.apache.flink:flink-cdc-pipeline-connectors | >=3.0.0 <3.5.0 | 3.5.0 |
| GHSA-wqm3-w3p6-xjgm | Maven | org.apache.flink:flink-connector-oracle-cdc | >=3.0.0 <3.5.0 | 3.5.0 |
| GHSA-wqm3-w3p6-xjgm | Maven | org.apache.flink:flink-connector-db2-cdc | >=3.0.0 <3.5.0 | 3.5.0 |
| GHSA-wqm3-w3p6-xjgm | Maven | org.apache.flink:flink-connector-sqlserver-cdc | >=3.0.0 <3.5.0 | 3.5.0 |
| GHSA-wqm3-w3p6-xjgm | Maven | org.apache.flink:flink-connector-mysql-cdc | >=3.0.0 <3.5.0 | 3.5.0 |