CVE-2025-61735
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected. Users are recommended to upgrade to version 5.0.3, which fixes the issue.
- CVSS 3.1
- 7.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - EPSS
- 1.0% chance of exploitation in the next 30 days; higher than 63% of CVEs (scores of 2026-10-25)
- CWE
- CWE-918
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:kylin
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-f6m8-qm7j-fh65 | Maven | org.apache.kylin:kylin | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-f6m8-qm7j-fh65 | Maven | org.apache.kylin:kylin-common-server | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-f6m8-qm7j-fh65 | Maven | org.apache.kylin:kylin-common-service | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-f6m8-qm7j-fh65 | Maven | org.apache.kylin:kylin-core-common | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-f6m8-qm7j-fh65 | Maven | org.apache.kylin:kylin-core-metadata | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-f6m8-qm7j-fh65 | Maven | org.apache.kylin:kylin-ops-server | >=4.0.0 <5.0.3 | 5.0.3 |
| GHSA-f6m8-qm7j-fh65 | Maven | org.apache.kylin:kylin-server | >=4.0.0 <5.0.3 | 5.0.3 |