cve.bz

CVE-2025-61594

2.1 lowEPSS 0.6%

Low (2.1) in ruby-lang uri. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in uri 0.12.5, 0.13.3, 1.0.4.

URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.

Severity

CVSS 4.0

2.1 low
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
0.6% chance of exploitation in the next 30 days; higher than 46% of CVEs (scores of 2026-10-31)
CWEs
CWE-200, CWE-212
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-j4pr-3wm6-xx2rRubyGemsuri<0.12.50.12.5
GHSA-j4pr-3wm6-xx2rRubyGemsuri>=0.13.0 <0.13.30.13.3
GHSA-j4pr-3wm6-xx2rRubyGemsuri>=1.0.0 <1.0.41.0.4

References

Check your stackJSON