{"cve":"CVE-2025-61594","nvd":{"published":"2025-12-30T21:15:43.893","modified":"2026-06-17T09:50:37.197","status":"Modified","description":"URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.","cvss_v4":{"vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N","score":2.1},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-200","CWE-212"],"references":["https://github.com/advisories/GHSA-22h5-pq3x-2gf2","https://github.com/ruby/uri/security/advisories/GHSA-j4pr-3wm6-xx2r","https://hackerone.com/reports/2957667","https://www.ruby-lang.org/en/news/2025/02/26/security-advisories"],"products":["ruby-lang:uri"],"source":"nvd","synced_at":"2026-10-19T22:18:08.089039631+00:00"},"epss":{"cve":"CVE-2025-61594","score":0.0056,"percentile":0.466,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-j4pr-3wm6-xx2r","url":"https://osv.dev/vulnerability/GHSA-j4pr-3wm6-xx2r","summary":"URI Credential Leakage Bypass over CVE-2025-27221","modified":"2026-09-10T03:50:58.735046368Z","packages":[{"ecosystem":"RubyGems","name":"uri","purl":"pkg:gem/uri","ranges":["<0.12.5"],"fixed":["0.12.5"]},{"ecosystem":"RubyGems","name":"uri","purl":"pkg:gem/uri","ranges":[">=0.13.0 <0.13.3"],"fixed":["0.13.3"]},{"ecosystem":"RubyGems","name":"uri","purl":"pkg:gem/uri","ranges":[">=1.0.0 <1.0.4"],"fixed":["1.0.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}