cve.bz

CVE-2025-59036

5.5 mediumEPSS 0.2%

Medium (5.5). EPSS 0.2% chance of exploitation in the next 30 days. Fixed in infrahub-server 1.3.9, 1.4.5.

Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
EPSS
0.2% chance of exploitation in the next 30 days; higher than 9% of CVEs (scores of 2026-10-31)
CWE
CWE-298
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-v2p7-4pv4-3wwhPyPIinfrahub-server<1.3.91.3.9
GHSA-v2p7-4pv4-3wwhPyPIinfrahub-server>=1.4.0 <1.4.51.4.5
PYSEC-2026-1463PyPIinfrahub-server<1.3.9
>=1.4.0 <1.4.5
1.3.9, 1.4.5

References

Check your stackJSON