{"cve":"CVE-2025-59036","nvd":{"published":"2025-09-09T22:15:34.303","modified":"2026-06-17T09:45:28.683","status":"Deferred","description":"Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L","score":5.5},"cwes":["CWE-298"],"references":["https://github.com/opsmill/infrahub/security/advisories/GHSA-v2p7-4pv4-3wwh"],"products":[],"source":"nvd","synced_at":"2026-10-19T22:08:41.295252406+00:00"},"epss":{"cve":"CVE-2025-59036","score":0.00194,"percentile":0.09176,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-v2p7-4pv4-3wwh","url":"https://osv.dev/vulnerability/GHSA-v2p7-4pv4-3wwh","summary":"Infrahub: Deleted and expired API tokens can still authenticate","modified":"2026-07-07T17:57:02.906392042Z","packages":[{"ecosystem":"PyPI","name":"infrahub-server","purl":"pkg:pypi/infrahub-server","ranges":["<1.3.9"],"fixed":["1.3.9"]},{"ecosystem":"PyPI","name":"infrahub-server","purl":"pkg:pypi/infrahub-server","ranges":[">=1.4.0 <1.4.5"],"fixed":["1.4.5"]}]},{"id":"PYSEC-2026-1463","url":"https://osv.dev/vulnerability/PYSEC-2026-1463","summary":"Infrahub: Deleted and expired API tokens can still authenticate","modified":"2026-07-07T17:47:15.591319861Z","packages":[{"ecosystem":"PyPI","name":"infrahub-server","purl":"pkg:pypi/infrahub-server","ranges":["<1.3.9",">=1.4.0 <1.4.5"],"fixed":["1.3.9","1.4.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}