cve.bz

CVE-2025-57107

7.1 highEPSS 0.2%

High (7.1) in vtk vtk. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in vtk 9.5.1.

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

Severity

CVSS 3.1

7.1 high
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 7% of CVEs (scores of 2026-10-31)
CWE
CWE-122
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
PYSEC-2025-225PyPIvtk<9.5.19.5.1

References

Check your stackJSON