cve.bz

CVE-2025-53689

8.8 highEPSS 0.5%

High (8.8) in apache jackrabbit. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in org.apache.jackrabbit:jackrabbit-spi-commons 2.20.17, 2.22.1, 2.23.2-beta.

Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 45% of CVEs (scores of 2026-10-31)
CWE
CWE-611
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-44c3-38h8-9fh9Mavenorg.apache.jackrabbit:jackrabbit-spi-commons>=2.20.0 <2.20.172.20.17
GHSA-44c3-38h8-9fh9Mavenorg.apache.jackrabbit:jackrabbit-spi-commons>=2.22.0 <2.22.12.22.1
GHSA-44c3-38h8-9fh9Mavenorg.apache.jackrabbit:jackrabbit-spi-commons>=2.23.0-beta <2.23.2-beta2.23.2-beta
GHSA-44c3-38h8-9fh9Mavenorg.apache.jackrabbit:jackrabbit-core>=2.23.0-beta <2.23.2-beta2.23.2-beta
GHSA-44c3-38h8-9fh9Mavenorg.apache.jackrabbit:jackrabbit-core>=2.20.0 <2.20.172.20.17
GHSA-44c3-38h8-9fh9Mavenorg.apache.jackrabbit:jackrabbit-core>=2.22.0 <2.22.12.22.1

References

Check your stackJSON