{"cve":"CVE-2025-53689","nvd":{"published":"2025-07-14T10:15:28.587","modified":"2026-06-17T09:38:42.977","status":"Modified","description":"Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges.\n\nUsers are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-611"],"references":["https://lists.apache.org/thread/5pf9n76ny13pzzk765og2h3gxdxw7p24","http://www.openwall.com/lists/oss-security/2025/07/14/1"],"products":["apache:jackrabbit"],"source":"nvd","synced_at":"2026-10-19T22:04:28.436527499+00:00"},"epss":{"cve":"CVE-2025-53689","score":0.0054,"percentile":0.45471,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-44c3-38h8-9fh9","url":"https://osv.dev/vulnerability/GHSA-44c3-38h8-9fh9","summary":"Apache Jackrabbit vulnerable to blind XXE attack due to insecure document build","modified":"2025-11-05T20:34:05.490798Z","packages":[{"ecosystem":"Maven","name":"org.apache.jackrabbit:jackrabbit-spi-commons","purl":"pkg:maven/org.apache.jackrabbit/jackrabbit-spi-commons","ranges":[">=2.20.0 <2.20.17"],"fixed":["2.20.17"]},{"ecosystem":"Maven","name":"org.apache.jackrabbit:jackrabbit-spi-commons","purl":"pkg:maven/org.apache.jackrabbit/jackrabbit-spi-commons","ranges":[">=2.22.0 <2.22.1"],"fixed":["2.22.1"]},{"ecosystem":"Maven","name":"org.apache.jackrabbit:jackrabbit-spi-commons","purl":"pkg:maven/org.apache.jackrabbit/jackrabbit-spi-commons","ranges":[">=2.23.0-beta <2.23.2-beta"],"fixed":["2.23.2-beta"]},{"ecosystem":"Maven","name":"org.apache.jackrabbit:jackrabbit-core","purl":"pkg:maven/org.apache.jackrabbit/jackrabbit-core","ranges":[">=2.23.0-beta <2.23.2-beta"],"fixed":["2.23.2-beta"]},{"ecosystem":"Maven","name":"org.apache.jackrabbit:jackrabbit-core","purl":"pkg:maven/org.apache.jackrabbit/jackrabbit-core","ranges":[">=2.20.0 <2.20.17"],"fixed":["2.20.17"]},{"ecosystem":"Maven","name":"org.apache.jackrabbit:jackrabbit-core","purl":"pkg:maven/org.apache.jackrabbit/jackrabbit-core","ranges":[">=2.22.0 <2.22.1"],"fixed":["2.22.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}