cve.bz

CVE-2025-48956

7.5 highEPSS 0.6%

High (7.5) in vllm vllm. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in vllm 0.10.1.1.

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 46% of CVEs (scores of 2026-10-31)
CWE
CWE-400
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rxc4-3w6r-4v47PyPIvllm>=0.1.0 <0.10.1.10.10.1.1
PYSEC-2026-2021PyPIvllm>=0.1.0 <0.10.1.10.10.1.1

References

Check your stackJSON