cve.bz

CVE-2025-48944

6.5 mediumEPSS 0.6%

Medium (6.5) in vllm vllm. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in vllm 0.9.0.

vLLM is an inference and serving engine for large language models (LLMs). In version 0.8.0 up to but excluding 0.9.0, the vLLM backend used with the /v1/chat/completions OpenAPI endpoint fails to validate unexpected or malformed input in the "pattern" and "type" fields when the tools functionality is invoked. These inputs are not validated before being compiled or parsed, causing a crash of the inference worker with a single request. The worker will remain down until it is restarted. Version 0.9.0 fixes the issue.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 50% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-vrq3-r879-7m65PyPIvllm>=0.8.0 <0.9.00.9.0
PYSEC-2026-2023PyPIvllm>=0.8.0 <0.9.00.9.0

References

Check your stackJSON