cve.bz

CVE-2025-48370

2.7 lowEPSS 0.9%

Low (2.7). EPSS 0.9% chance of exploitation in the next 30 days. Fixed in @supabase/auth-js 2.70.0.

auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.

Severity

CVSS 4.0

2.7 low
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U
EPSS
0.9% chance of exploitation in the next 30 days; higher than 59% of CVEs (scores of 2026-10-31)
CWEs
CWE-22, CWE-287
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8r88-6cj9-9fh5npm@supabase/auth-js<2.70.02.70.0

References

Check your stackJSON