cve.bz

CVE-2025-48068

2.3 lowEPSS 0.2%

Low (2.3) in vercel next.js. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in next 14.2.30, 15.2.2.

Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.

Severity

CVSS 4.0

2.3 low
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

CVSS 3.1

4.3 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
EPSS
0.2% chance of exploitation in the next 30 days; higher than 10% of CVEs (scores of 2026-10-31)
CWE
CWE-1385
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3h52-269p-cp9rnpmnext>=15.0.0 <15.2.215.2.2
GHSA-3h52-269p-cp9rnpmnext>=13.0 <14.2.3014.2.30

References

Check your stackJSON